  <!doctype html>

<html lang="en" class="bni articlePage ">
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Dennis A. Will - Albert Lea Tribune | Albert Lea Tribune</title><link rel="preload" href="https://www.albertleatribune.com/wp-content/themes/2021-albertlea-child/media/img/brand/logo-white-albertlea.png" as="image" /><link rel="preload" href="https://www.albertleatribune.com/wp-content/themes/2021-albertlea-child/media/img/brand/logo-white-mobile-albertlea.png" as="image" /><link rel="preload" href="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/img/Search_icon-black.png" as="image" /><link rel="preload" href="https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?w=225" as="image" imagesrcset="https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg 549w, https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?resize=225,300 225w, https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?resize=263,350 263w, https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?resize=104,139 104w" imagesizes="(max-width: 225px) 100vw, 225px" />

        <meta name="viewport" content="width=device-width, initial-scale=1">

        
        <link href="https://www.albertleatribune.com/wp-content/themes/2021-bni/style.css?1670448254" as="style">

								<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/splide/dist/css/splide.min.css?1670425127" />
				<link rel="stylesheet" href="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/css/normalize.css?1670425127" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.albertleatribune.com/wp-content/themes/2021-bni/style.css?1670448254" />

        <script defer="defer" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/vendors/modernizr-2.6.2.min.js?1670425127" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.albertleatribune.com/wp-content/themes/2021-albertlea-child/media/img/brand/favicon-albertlea.png">

				
				<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.11 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://www.albertleatribune.com/2022/12/dennis-a-will/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Dennis A. Will - Albert Lea Tribune" />
	<meta property="og:description" content="Dennis Allen Will of Albert Lea passed away on December 16, 2022. A funeral service will be held at Bayview/Freeborn Funeral home on Wednesday, December 21, 2022 at 11am, with burial to follow at Pilgrim’s Rest Cemetery in Myrtle, MN. A visitation will be held 1 hour prior to the service. Dennis was born on [&hellip;]" />
	<meta property="og:url" content="https://www.albertleatribune.com/2022/12/dennis-a-will/" />
	<meta property="og:site_name" content="Albert Lea Tribune" />
	<meta property="article:published_time" content="2022-12-20T10:52:47+00:00" />
	<meta property="og:image" content="https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?w=225" />
	<meta name="author" content="Submitted" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Submitted" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://www.albertleatribune.com/2022/12/dennis-a-will/","url":"https://www.albertleatribune.com/2022/12/dennis-a-will/","name":"Dennis A. Will - Albert Lea Tribune","isPartOf":{"@id":"https://www.albertleatribune.com/#website"},"primaryImageOfPage":{"@id":"https://www.albertleatribune.com/2022/12/dennis-a-will/#primaryimage"},"image":{"@id":"https://www.albertleatribune.com/2022/12/dennis-a-will/#primaryimage"},"thumbnailUrl":"https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?w=225","datePublished":"2022-12-20T10:52:47+00:00","dateModified":"2022-12-20T10:52:47+00:00","author":{"@id":"https://www.albertleatribune.com/#/schema/person/06a93aac9426ef877daffcf2299f65b6"},"breadcrumb":{"@id":"https://www.albertleatribune.com/2022/12/dennis-a-will/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.albertleatribune.com/2022/12/dennis-a-will/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.albertleatribune.com/2022/12/dennis-a-will/#primaryimage","url":"https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?w=225","contentUrl":"https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?w=225"},{"@type":"BreadcrumbList","@id":"https://www.albertleatribune.com/2022/12/dennis-a-will/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.albertleatribune.com/"},{"@type":"ListItem","position":2,"name":"Dennis A. Will"}]},{"@type":"WebSite","@id":"https://www.albertleatribune.com/#website","url":"https://www.albertleatribune.com/","name":"Albert Lea Tribune","description":"Local news, sports, weather, opinions, obituaries","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.albertleatribune.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.albertleatribune.com/#/schema/person/06a93aac9426ef877daffcf2299f65b6","name":"Submitted","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.albertleatribune.com/#/schema/person/image/","url":"https://www.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?w=96","contentUrl":"https://www.albertleatribune.com/wp-content/uploads/sites/14/2020/10/Tribune.jpg?w=96","caption":"Submitted"},"url":"https://www.albertleatribune.com/author/submitted-2/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel="alternate" type="application/rss+xml" title="Albert Lea Tribune &raquo; Dennis A. Will Comments Feed" href="https://www.albertleatribune.com/2022/12/dennis-a-will/feed/" />
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.albertleatribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<style id='wp-parsely-recommendations-style-inline-css'>
.parsely-recommendations-list-title{font-size:1.2em}.parsely-recommendations-list{list-style:none;padding:unset}.parsely-recommendations-cardbody{overflow:hidden;padding:.8em;text-overflow:ellipsis;white-space:nowrap}.parsely-recommendations-cardmedia{padding:.8em .8em 0}

</style>
<link rel='stylesheet' id='all-css-2' href='https://www.albertleatribune.com/_static/??-eJx9jUkOwjAMRS9EEloBXSHOkjqmGJxBsaOqt6ddIFEhsfzD03NzMZSAW0BxT3ERA3lkjJh0Fwr7BathnDwsNlKyIHJw//B1+847CHLS7VO4TZQ2UGtOqKbUfCdGUwi0VXSBRN3IGV5iRRdGOzbi8GtfCwfsRQiMPlajfIS3eO0uw/HUn7t+eAN1/Vns' type='text/css' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-4' href='https://www.albertleatribune.com/_static/??-eJyNUNtOwzAM/SFcL0Ma4gHxKchNvNbgXFQnmvb3pAUeRpnEixWfW6yDlwKSvLbAht4MA9ksPicboqShIw/4W0KhUzDSciPpnsqpYtE2SbIVKlnVcJvQZXelJrEog1U6n0HFOtNGFb/9tiPhi9yl1Zljv/B4ODogHXmpygR+Fg1o9aq8c8QGPye8cy3kP8C54YQxh6Y9ymZaOFAI1+0pafp3xFtvDC17IQXNU7ab5c/i7kWtJXwDq+c1vrjTkzs8PjvnPgFeTKMu' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.albertleatribune.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<script type="pmdelayedscript" src="https://www.albertleatribune.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZuYGRuaGBoVEWAK9DIhM=" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script><script src="https://www.albertleatribune.com/wp-content/plugins/trinity-audio/js/the_content-hook-script.js?ver=6.1.1" id="the_content-hook-script-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="the_content-hook-script-js-after" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
console.debug('TRINITY_WP', 'Skip player from rendering', 'is single: 1, is main loop: , is main query: 1', 'TS: 2022-12-20 13:12:28');
</script>
<link rel="https://api.w.org/" href="https://www.albertleatribune.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.albertleatribune.com/wp-json/wp/v2/posts/785153" /><link rel='shortlink' href='https://www.albertleatribune.com/?p=785153' />
<link rel="alternate" type="application/json+oembed" href="https://www.albertleatribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.albertleatribune.com%2F2022%2F12%2Fdennis-a-will%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.albertleatribune.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.albertleatribune.com%2F2022%2F12%2Fdennis-a-will%2F&#038;format=xml" />
<style type="text/css">
.feedzy-rss-link-icon:after {
	content: url("https://www.albertleatribune.com/wp-content/plugins/feedzy-rss-feeds/img/external-link.png");
	margin-left: 3px;
}
</style>
		<link href="https://trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
	<style>img#wpstats{display:none}</style>
		<meta name="google-site-verification" content="V_GdI8BpuhtAvIqQr_W1pg0sDroZdM_rzcMHst2Vs38" />

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4352474-1', 'auto');
  ga('send', 'pageview');

</script>

      <meta name="onesignal" content="wordpress-plugin"/>
            <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = 'OneSignalSDKUpdaterWorker.js';
                      OneSignal.SERVICE_WORKER_PATH = 'OneSignalSDKWorker.js';
                      OneSignal.SERVICE_WORKER_PARAM = { scope: '/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/push/onesignal/' };
        OneSignal.setDefaultNotificationUrl("https://www.albertleatribune.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '96759232-ccda-453c-a61e-44e3159a8625';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.albertleatribune.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.1f7bf174-83d3-440c-93ed-a44b9d28ad31";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "Be the first to know! Get news notifications and you can cancel anytime.";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
				      
                <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">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</script>



				<script defer="defer" type="pmdelayedscript" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/colorbox/jquery.colorbox-min.js" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <link href="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/colorbox/colorbox.css" rel="stylesheet">

        <script src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/assets/optimera/optiCommon-1.0.0.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
          var optiCommon = optiCommon || {};

          /**
           * Set the Optimera data splitter parameters
           * additionalOptimeraParams can be empty, only the default device type will be included automatically.
           * CustomParams can be set to add a loggedIn parameter to be set later. 
           * */
           optiCommon.init({
           splitters: {
           additionalOptimeraParams: [],
             customParams: ['loggedIn'],
          }
          });
        </script>


                <script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/pndM4AxNqR8GTouy9whV51KEs4jW17f4LeUmmFLafWDs7rGxUw0ekVgT_O2T3YfAskC1t86bnrIqSw",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>


        
                  
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
		console.log('%c TESTING OPT V 1.1', 'background: #222; color: red; font-weigit: bold;');
    opt_loggedin = loggedin.toString();
    optiCommon.setCustomParam({
      'name': 'loggedIn', // must match the param name set in the init above
      'value': opt_loggedin, // must be a string, not bool
    });

  </script>

  <!-- DFP Work -->
    
        <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>

        <link rel="stylesheet" type="text/css" href="https://htlbid.com/v3/albertleatribune.com/htlbid.css" />
    <script src="https://htlbid.com/v3/albertleatribune.com/htlbid.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
     
<script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
  window.googletag = window.googletag || {cmd: []};
  window.htlbid = window.htlbid || {};
  htlbid.cmd = htlbid.cmd || [];
  htlbid.cmd.push(function() {
          htlbid.setTargeting('is_testing', 'no');
    
      htlbid.setFirstPartyData({
        site: {
          keywords: 'obituaries, '
        }
      });

  });



googletag.cmd.push(function() {

    			googletag.defineSlot('/1613683/ALNI-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());
			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/ALNI-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());
    
        if (!loggedin) {
			googletag.defineSlot('/1613683/ALNI-1x1-wall', [1,1], 'div-gpt-ad-one_by_one_wall').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  } else {
			googletag.defineSlot('/1613683/ALNI-sub-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
  }
       

    			googletag.defineSlot('/1613683/ALNI-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-300x250-12', [300, 250], 'div-gpt-ad-bigblock-12').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-300x250-13', [300, 250], 'div-gpt-ad-bigblock-13').addService(googletag.pubads());
			googletag.defineSlot('/1613683/ALNI-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());

			googletag.defineSlot('/1613683/ALNI-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());

      var large_leaderboard_one = googletag
        .defineSlot('/1613683/ALNI-970x250-1', [[970, 90], [970, 250], [728, 90], [320, 50]], 'div-gpt-ad-largeleaderboard-one')
        .addService(googletag.pubads());
          var large_leaderboard_four = googletag
        .defineSlot('/1613683/ALNI-970x250-4', [[970, 90], [970, 250], [728, 90], [320, 50]], 'div-gpt-ad-largeleaderboard-four')
        .addService(googletag.pubads());

      var leaderboard_mapping = googletag.sizeMapping()
        .addSize([970, 728], [[970, 250], [970, 90], [728, 90]])
        .addSize([320, 240], [320, 50])
        .addSize([0, 0], [])
        .build();

      large_leaderboard_one.defineSizeMapping(leaderboard_mapping);
          large_leaderboard_four.defineSizeMapping(leaderboard_mapping);

      
      if (!loggedin) {
          googletag.defineOutOfPageSlot('/1613683/ALNI-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
      } else {
          googletag.defineOutOfPageSlot('/1613683/ALNI-sub-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
      }

       



                          googletag.pubads().setTargeting("catname", [ "obituaries",  ]);
                        


          googletag.pubads().setTargeting("pageurl", "/2022/12/dennis-a-will/");
    
    
		googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
    googletag.enableServices();

});


</script>


        
                
	                  <script defer="defer" type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
      


          </head>
		<body id="articlePage" class="">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
                
				<div id="" class="undertone">

            <div id="sup_nav" class="sup_nav single">
    <div class="wrapper">
      <div id="logo">
        <a href="https://www.albertleatribune.com" class="desktop">
          <img data-perfmatters-preload src="https://www.albertleatribune.com/wp-content/themes/2021-albertlea-child/media/img/brand/logo-white-albertlea.png" alt="Albert Lea Tribune" />
        </a>
        <a href="https://www.albertleatribune.com" class="mobile">
          <img data-perfmatters-preload src="https://www.albertleatribune.com/wp-content/themes/2021-albertlea-child/media/img/brand/logo-white-mobile-albertlea.png" alt="Albert Lea Tribune" />
        </a>
      </div>
      <div class="right_items">
        <div class="share_buttons_group">
        <div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-785153" class="share-facebook sd-button share-icon no-text" href="https://www.albertleatribune.com/2022/12/dennis-a-will/?share=facebook" target="_blank" title="Click to share on Facebook" ><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-785153" class="share-twitter sd-button share-icon no-text" href="https://www.albertleatribune.com/2022/12/dennis-a-will/?share=twitter" target="_blank" title="Click to share on Twitter" ><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="mailto:?subject=%5BShared%20Post%5D%20Dennis%20A.%20Will&body=https%3A%2F%2Fwww.albertleatribune.com%2F2022%2F12%2Fdennis-a-will%2F&share=email" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="8aeddaa9a2" data-email-share-track-url="https://www.albertleatribune.com/2022/12/dennis-a-will/?share=email"><span></span><span class="sharing-screen-reader-text">Click to email a link to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.albertleatribune.com/2022/12/dennis-a-will/#print" target="_blank" title="Click to print" ><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>        </div>
        <div id="right_items_extra">
        <span id="login_link"></span>
<span id="subscribe_button"><a href="/subscriptions/" class="subscribe">Subscribe</a></span>        </div>
      </div>
    </div>
    <nav role="navigation">
      <div class="wrapper">
        <div id="menuToggle">
          <input type="checkbox" />
          <span></span>
          <span></span>
          <span></span>
          
	
        <ul id="menu-main" class="menu"><li id="menu-item-764588" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-764588"><a href="https://www.albertleatribune.com/">Home</a></li>
<li id="menu-item-764589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-764589"><a href="https://www.albertleatribune.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-765470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-765470"><a href="https://www.albertleatribune.com/category/lifestyles/">Arts &amp; Culture</a>
	<ul class="sub-menu">
		<li id="menu-item-765862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765862"><a href="https://www.albertleatribune.com/category/lifestyles/lifestyles-features/">Arts &amp; Culture features</a></li>
		<li id="menu-item-765861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765861"><a href="https://www.albertleatribune.com/category/lifestyles/lifestyles-columns/">Arts &amp; Culture columns</a></li>
		<li id="menu-item-765471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765471"><a href="https://www.albertleatribune.com/category/lifestyles/birth-announcements/">Birth Announcements</a></li>
		<li id="menu-item-765472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765472"><a href="https://www.albertleatribune.com/category/lifestyles/campus-notes/">Campus Notes</a></li>
		<li id="menu-item-765473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765473"><a href="https://www.albertleatribune.com/category/lifestyles/engagements/">Engagements</a></li>
		<li id="menu-item-765475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765475"><a href="https://www.albertleatribune.com/category/lifestyles/weddings/">Weddings</a></li>
		<li id="menu-item-765474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765474"><a href="https://www.albertleatribune.com/category/lifestyles/faith/">Faith</a></li>
		<li id="menu-item-765863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765863"><a href="https://www.albertleatribune.com/category/lifestyles/organizations/">Organizations</a></li>
	</ul>
</li>
	<li id="menu-item-765864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765864"><a href="https://www.albertleatribune.com/category/news/courts-and-crime/">Cops, Courts &amp; Fires</a></li>
	<li id="menu-item-765865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765865"><a href="https://www.albertleatribune.com/category/news/education-news/">Education</a></li>
	<li id="menu-item-765866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765866"><a href="https://www.albertleatribune.com/category/news/elections/">Elections &amp; Campaigns</a></li>
	<li id="menu-item-765867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765867"><a href="https://www.albertleatribune.com/category/health-updates/">Health Updates</a></li>
	<li id="menu-item-772376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-772376"><a href="https://www.albertleatribune.com/category/progress-2022/">Progress 2022</a></li>
	<li id="menu-item-765869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765869"><a href="https://www.albertleatribune.com/category/news/state/">State &amp; Regional</a></li>
	<li id="menu-item-765476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765476"><a href="https://www.albertleatribune.com/category/news/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-764592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764592"><a href="https://www.albertleatribune.com/category/sports/">Sports</a></li>
<li id="menu-item-764593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-764593"><a href="https://www.albertleatribune.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-765870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765870"><a href="https://www.albertleatribune.com/category/opinion/editorials/">Editorials</a></li>
	<li id="menu-item-765871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-765871"><a href="https://www.albertleatribune.com/category/albertleamagazine/columns-albertleamagazine/">Columns</a>
	<ul class="sub-menu">
		<li id="menu-item-765884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765884"><a href="https://www.albertleatribune.com/category/opinion/columns/exit-22/">Al Batt</a></li>
		<li id="menu-item-765883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765883"><a href="https://www.albertleatribune.com/category/opinion/columns/nose-for-news/">Sarah Stultz</a></li>
		<li id="menu-item-765882" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765882"><a href="https://www.albertleatribune.com/category/opinion/columns/every-little-thing/">April Jeppson</a></li>
		<li id="menu-item-765872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765872"><a href="https://www.albertleatribune.com/category/opinion/columns/guest-columns/">Guest Columns</a></li>
	</ul>
</li>
	<li id="menu-item-765873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-765873"><a href="https://www.albertleatribune.com/category/opinion/letterstoeditor/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-764595" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-764595"><a href="https://www.albertleatribune.com/category/obituaries/">Obits</a>
<ul class="sub-menu">
	<li id="menu-item-765874" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-765874"><a href="https://www.albertleatribune.com/obituary-information-and-guidelines/">Obituary Information And Guidelines</a></li>
</ul>
</li>
<li id="menu-item-764596" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-764596"><a href="https://www.albertleatribune.com/services/">Services</a>
<ul class="sub-menu">
	<li id="menu-item-764597" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764597"><a href="https://www.albertleatribune.com/services/about-us/">About Us</a></li>
	<li id="menu-item-764598" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764598"><a href="https://www.albertleatribune.com/services/policies/">Policies</a></li>
	<li id="menu-item-764599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764599"><a href="https://www.albertleatribune.com/advertisewithus/">Advertise with Us</a></li>
	<li id="menu-item-764600" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764600"><a href="https://www.albertleatribune.com/services/submit-a-news-tip/">News Tip</a></li>
	<li id="menu-item-764601" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764601"><a href="https://www.albertleatribune.com/services/submit-a-photo/">Photo</a></li>
	<li id="menu-item-764602" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764602"><a href="https://www.albertleatribune.com/send-a-video-form/">Send a Video</a></li>
	<li id="menu-item-764603" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764603"><a href="https://www.albertleatribune.com/photo-order-form-new/">photo order form</a></li>
	<li id="menu-item-764604" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764604"><a href="https://www.albertleatribune.com/services/submit-a-letter-to-the-editor/">Submit a Letter to the Editor</a></li>
	<li id="menu-item-784120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-784120"><a href="https://www.albertleatribune.com/services/engagement-announcement/">Engagement Announcement</a></li>
	<li id="menu-item-784121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-784121"><a href="https://www.albertleatribune.com/services/wedding-announcement/">Wedding Announcement</a></li>
</ul>
</li>
<li id="menu-item-764605" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764605"><a href="https://www.albertleatribune.com/contests/">Contests</a></li>
<li id="menu-item-764606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764606"><a href="https://www.albertleatribune.com/category/albertleamagazine/">Albert Lea Magazine</a></li>
<li id="menu-item-764607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-764607"><a href="https://marketplace.albertleatribune.com/AdHunter/AlbertLea">Classifieds</a></li>
<li id="menu-item-764608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764608"><a href="https://www.albertleatribune.com/category/public-notices/">Public Notices</a></li>
<li id="menu-item-764609" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-764609"><a href="https://digital.albertleatribune.com">E-Edition</a></li>
<li class="search_bar"> <form id="search_bar" action="https://www.albertleatribune.com/site-search/" class="search_bar_form" method="get" tabindex="0"> <img data-perfmatters-preload src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/img/Search_icon-black.png" width="30" height="30" /> <input type="text" name="q" class="searchQuery" placeholder="Search Albert Lea Tribune..." value="" /> <input type="submit" class="searchButton" value="Go" /> </form> </li></ul>
        </div>
      </div>
    </nav>
  </div>

					<div id="main_body" class="wrapper">
        <!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-screenshift');
    });
  </script>
</div> 

						<div id="content" class="flownews">
							<div id="notifications">
																
																							</div>

        <div class="ad mobile_sticky_top">
          <div class="large_leaderboard"><!-- ROS_970x250-1 -->
<div id='div-gpt-ad-largeleaderboard-one'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-largeleaderboard-one');
    });
  </script>
</div></div>
        </div>


  <div class="one_by_one_group">
  <!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-one_by_one_wall');
    });
  </script>
</div>  </div>
 

	  <div class="page_type-story">
  
  <div class="main_column">
    <div class="story">
      
      

      <div id="article">


        

        <div class="story_grid">
          <div class="story_detail">

            <div class="one_by_one_group">
              <!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_one_by_one_two');
    });
  </script>
</div>              <!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_oop');
    });
  </script>
</div>            </div>
            <div id="story_one_by_one_group" class="one_by_one_group">
              <!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_one_by_one');
    });
  </script>
</div>            </div>

            <div id="article_info">

              
              <h2 class="headline">Dennis A. Will</h2>

              <p class="pubStamp">Published 4:52 am Tuesday, December 20, 2022</p>

                            <div class="byline">
                
                <p class="author">
                          <strong>By <a href="https://www.albertleatribune.com/author/submitted-2/" rel="bookmark">Submitted</a></strong>

                                  </p>
                                <div class="clearfix"></div>
              </div><!-- END BYLINE -->
                          </div>

              <div class="gallery_group">
      <div id="story_photo_group">
        
                                    

              </div>
    </div>

            <div class="modulist-rss--content-container">
<p>Dennis Allen Will of Albert Lea passed away on December 16, 2022. A funeral service will be held at Bayview/Freeborn Funeral home on Wednesday, December 21, 2022 at 11am, with burial to follow at Pilgrim’s Rest Cemetery in Myrtle, MN. A visitation will be held 1 hour prior to the service.</p>
<div id="attachment_785154" style="width: 235px" class="wp-caption alignright"><a href="https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg"><img data-perfmatters-preload aria-describedby="caption-attachment-785154" decoding="async" class="size-medium wp-image-785154" src="https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?w=225" alt="" width="225" height="300" srcset="https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg 549w, https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?resize=225,300 225w, https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?resize=263,350 263w, https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/12/63a0c95ed142190234fbd93d-4pcLIP.jpeg?resize=104,139 104w" sizes="(max-width: 225px) 100vw, 225px" /></a><p id="caption-attachment-785154" class="wp-caption-text">Dennis A. Will</p></div>
<p>Dennis was born on December 8th, 1928 to Clarence and Lenore Will at the family farm near Myrtle. Dennis had a twin brother Hillis, who passed away at the age of 2 ½ . Dennis attended Myrtle Country School through 8th grade. After school, he helped his dad on the farm. Dennis met Kathryn Peterson at Carl’s Roller Rink in Albert Lea in 1953. Later that year, on December 27, 1953 Dennis and Kathryn were united in marriage. To this union, they had one son, Mark.</p>
<p>In March 1954 to March 1956, Dennis was drafted in the Army and spent one year in Germany. They lived on the family farm where Dennis farmed, worked at the Northwood Implement Shop and later drove Semi truck over the road. Dennis and Kathryn enjoyed traveling together exploring the U.S.</p>
<div class="ad count6"><div id='div-gpt-ad-bigblock-1'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-1');
    });
  </script>
</div></div><div class="instory_widget"><div class="textwidget custom-html-widget"><h3 class="section">
	Email newsletter signup
</h3>
<!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
  <form action="https://albertleatribune.us12.list-manage.com/subscribe/post?u=7b8adb203b7cd2e32e216cfea&amp;id=ce1703517a&amp;f_id=00deb7e0f0" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">Sign up for our daily email newsletter</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="add your email address here, cancel anytime" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2ee854691155dc4dbeba498c5_8685ffdc78" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->
</div></div><p>Dennis is proceeded in death by his wife Kathryn in 2021, who he missed dearly and now they are together again. Plus other dear family members.</p>
<p>Dennis is survived by his son Mark of Albert Lea, grandchildren, step grandchildren, great step grandchildren, nieces, nephews and friends.</p>
<div class="modulist-rss--image-container"></div>
</div>
<div class="ad"><div id='div-gpt-ad-bigblock-2'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-2');
    });
  </script>
</div></div><div class="ad"><div id='div-gpt-ad-bigblock-instory-third'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-instory-third');
    });
  </script>
</div></div><div id="cedato-unit"></div><div class="ad"><div id='div-gpt-ad-bigblock-3'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-3');
    });
  </script>
</div></div>
            <div id="comments"> </div><!-- END comments -->
            
                                  


              <div id="NTV_1"></div>

                      
<div class="more_to_explore">
  <h4>More Obituaries</h4>
  
        <div class="story">
                    <h3><a href="https://www.albertleatribune.com/2022/12/darlene-engel/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Darlene Engel">Darlene Engel</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://www.albertleatribune.com/2022/12/carolyn-mae-brenegan/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Carolyn Mae Brenegan">Carolyn Mae Brenegan</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://www.albertleatribune.com/2022/12/norma-lois-jensen-walk-3/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Norma Lois Jensen Walk">Norma Lois Jensen Walk</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://www.albertleatribune.com/2022/12/marlene-m-boerner/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Marlene M. Boerner">Marlene M. Boerner</a></h3>

          <div class="clearfix"></div>
        </div>

        
</div>
          
            
            
											<div class="print_this bubble_buttons">
													<a href="#">Print Article</a>
											</div><!-- END print_this -->


            <div class="articleOptions bubble_buttons">
              <div class="admin">
</div>
<div class="clearfix"></div>


            </div>

                        
              

  <div class="rev_ad">
    <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="134049"></div>
      <script type="pmdelayedscript" src="https://assets.revcontent.com/master/delivery.js" defer="defer" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
  </div>


<div class="one_by_one_group">
<div id="rev_video"></div>
</div>



            
            </div><!-- END STORY_DETAIL -->

            <div class="sidebar">
                  
<ul class="sidebar">
	<li>
		<div class="ad ">
			<div id='div-gpt-ad-bigblock-12'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-12');
    });
  </script>
</div>		</div>
	</li>
	<li id="rpwe_widget-7" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Construction Updates</h2>
<div  class="rpwe-block"><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.albertleatribune.com/2022/11/main-street-project-finished-in-albert-lea/" target="_self"><img class="rpwe-alignleft rpwe-thumb" src="https://www.albertleatribune.com/wp-content/uploads/sites/14/2022/11/1119.main_.street-45x45.jpg" alt="Main Street project finished in Albert Lea" height="45" width="45" loading="lazy" decoding="async"></a><h3 class="rpwe-title"><a href="https://www.albertleatribune.com/2022/11/main-street-project-finished-in-albert-lea/" target="_self">Main Street project finished in Albert Lea</a></h3><time class="rpwe-time published" datetime="2022-11-18T16:27:05-06:00">November 18, 2022</time></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-13'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-13');
    });
  </script>
</div>		</div>
	</li>
		<li>
		<div class="story_list widget">
			<ul>
							</ul>
		</div>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-18'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-18');
    });
  </script>
</div>		</div>
	</li>
	<li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">		<div class="teaseStory special_sections_block">
			<h3 class="section">Special Section</h3>
      <iframe src="https://static.issuu.com/widgets/shelf/index.html?folderId=162e6c4c-a527-4937-a864-261a496a11c3&amp;theme=theme2&amp;rows=2&amp;thumbSize=large&amp;roundedCorners=false&amp;showTitle=false&amp;showAuthor=false&amp;shadow=true&amp;effect3d=true](https://static.issuu.com/widgets/shelf/index.html?folderId=162e6c4c-a527-4937-a864-261a496a11c3&theme=theme2&rows=2&thumbSize=large&roundedCorners=false&showTitle=false&showAuthor=false&shadow=true&effect3d=true)" frameborder="0" marginwidth="0" marginheight="0" scrolling="no" width="100%" height="370"></iframe>

			<div class="more_stories">
				<h4><a href="https://www.albertleatribune.com/special-promos/" class="moreLink" rel="bookmark">More special sections</a></h4>
			</div>
		</div>

			<h3 class="section">Financials</h3>

			<div id="twitterBox300x" class="clearFix">
			<!--START theFinancials.com Content-->
			<!--copyright theFinancials.com - All Rights Reserved-->
			<iframe src='https://www.thefinancials.com/free/EXm_MarketUpdate_US.html' width='100%' marginheight='0' marginwidth='0' height='400' hspace='0' vspace='0' frameborder='no' style='margin-bottom:12px' title='US Market Update'><br /></iframe>
			<!--END theFinancials.com Content-->
			<br />
</div></div></li>
  </ul>
    <div class="sticky">
      <div class="ad">
        <div id='div-gpt-ad-halfpage-1'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-halfpage-1');
    });
  </script>
</div>      </div>
    </div>            </div>
            <div class="right_rule"></div>
        </div>

    </div>
  </div>

</div>

  

	<div class="clearfix"></div>
    <div id="mobile_sticky_bottom_group" class="ad mobile_sticky_bottom">
      <div class="large_leaderboard"><!-- ROS_970x250-4 -->
<div id='div-gpt-ad-largeleaderboard-four'>
  <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-largeleaderboard-four');
    });
  </script>
</div></div>
    </div>
					</div>
					<div id="footer" class="clearfix">
            <div class="wrapper">
              <div id="footSections" class="col">
	                <h4>Sections</h4>
                <ul id="menu-footer-sections" class="menu"><li id="menu-item-764610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-764610"><a href="https://www.albertleatribune.com/">Home</a></li>
<li id="menu-item-764611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764611"><a href="https://www.albertleatribune.com/category/news/">News</a></li>
<li id="menu-item-764612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764612"><a href="https://www.albertleatribune.com/category/sports/">Sports</a></li>
<li id="menu-item-764613" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764613"><a href="https://www.albertleatribune.com/category/opinion/">Opinion</a></li>
<li id="menu-item-764614" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-764614"><a href="https://www.albertleatribune.com/category/lifestyles/">Arts &amp; Culture</a></li>
<li id="menu-item-764615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-764615"><a href="https://marketplace.albertleatribune.com/AdHunter/AlbertLea">Classifieds</a></li>
<li id="menu-item-764616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-764616"><a href="https://smb.albertleatribune.com/">Small Business</a></li>
</ul>              </div>


              <div id="footServices" class="col">
	                <h4>Services</h4>
                <ul id="menu-footer-services" class="menu"><li id="menu-item-764617" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764617"><a href="https://www.albertleatribune.com/services/about-us/">About Us</a></li>
<li id="menu-item-764619" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764619"><a href="https://www.albertleatribune.com/services/policies/">Policies</a></li>
<li id="menu-item-764620" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764620"><a href="https://www.albertleatribune.com/services/submit-a-news-tip/">News Tip</a></li>
<li id="menu-item-776453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-776453"><a href="https://www.albertleatribune.com/subscriptions/">Subscriptions</a></li>
</ul>              </div>


              <div id="footCopyright" class="col">
                                <h4>Copyright</h4>
                <ul>
                  <li>&copy; 2022, Albert Lea Tribune</li>
                </ul>

              </div>
            </div>

					</div>
				</div>


				        <script defer="defer" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/splide/dist/js/splide.min.js?1670425127" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/vendors/jquery.contentcarousel.js?1670425127" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/vendors/jquery.easing.1.3.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
				<script defer="defer" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/vendors/jquery.timeago.js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/plugins.js?1670425127" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        <script defer="defer" src="https://www.albertleatribune.com/wp-content/themes/2021-bni/media/js/main.js?1670425127" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>

        
				
<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">tb_pathToImage = "https://www.albertleatribune.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.albertleatribune.com/wp-includes/js/thickbox/tb-close.png";</script>

	<script type="pmdelayedscript" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
		window.WPCOM_sharing_counts = {"https:\/\/www.albertleatribune.com\/2022\/12\/dennis-a-will\/":785153};
	</script>
				<link rel='stylesheet' id='all-css-0' href='https://www.albertleatribune.com/wp-content/plugins/recent-posts-widget-extended/assets/css/rpwe-frontend.css?m=1670425127g' type='text/css' media='all' />
<script type="pmdelayedscript" src="https://www.albertleatribune.com/_static/??/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js,/wp-includes/js/hoverintent-js.min.js?m=1670425127j" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script><script src="https://www.albertleatribune.com/wp-includes/js/admin-bar.min.js?ver=6.1.1" id="admin-bar-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="admin-bar-js-after" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {
		var searchValRegex = new RegExp( $(this).val(), 'i');
		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {
			return searchValRegex.test( $(this).find('> a').text() );
		}).show();
	});
});
</script>
<script id="wp-polls-js-extra" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
var pollsL10n = {"ajax_url":"https:\/\/www.albertleatribune.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script type="pmdelayedscript" src="https://www.albertleatribune.com/wp-content/plugins/wp-polls/polls-js.js?m=1670425127g" data-perfmatters-type="text/javascript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script><script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=6.1.1" async="async" id="remote_sdk-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="sharing-js-js-extra" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src="https://www.albertleatribune.com/wp-content/mu-plugins/jetpack-11.6/_inc/build/sharedaddy/sharing.min.js?ver=11.6" id="sharing-js-js" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
<script id="sharing-js-js-after" type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
	<script src="https://stats.wp.com/e-202251.js" defer type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
	<script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'173113710',post:'785153',tz:'-6',srv:'www.albertleatribune.com',hp:'vip',j:'1:11.6'} ]);
		_stq.push([ 'clickTrackerInit', '173113710', '785153' ]);
	</script>				</div><!-- END undertone -->
        				<script defer="defer" id="dsq-count-scr" src="//albertleatribune.disqus.com/count.js" async type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1"></script>
        
                <script type="pmdelayedscript" data-cfasync="false" data-no-optimize="1" data-no-defer="1" data-no-minify="1">
document.addEventListener("DOMContentLoaded", function() {
  htlbid.cmd.push(() => {
    htlbid.refresh();
  });  
});
</script>
        
    <script type="text/javascript" id="perfmatters-delayed-scripts-js">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</script></body>
</html>